#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+(?=<img)"
Local $sString = "Your password 5gIlrjtxDy<img src="some link />" & @CRLF & _
"" & @CRLF & _
"// v1: \S+(?=<img)" & @CRLF & _
"// v2: (?<=\s)\w+(?=<img)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")