$re = '/\S+(?=<img)/';
$str = 'Your password 5gIlrjtxDy<img src="some link />
// v1: \\S+(?=<img)
// v2: (?<=\\s)\\w+(?=<img)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);