re = /\S+(?=<img)/
str = 'Your password 5gIlrjtxDy<img src="some link />
// v1: \\S+(?=<img)
// v2: (?<=\\s)\\w+(?=<img)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end