using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+(?=<img)";
string input = @"Your password 5gIlrjtxDy<img src=""some link />
// v1: \S+(?=<img)
// v2: (?<=\s)\w+(?=<img)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}