#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!_+(?:[.-]?_*)*)\w+(?:[-.]?\w+)*@gmail\.com$"
Local $sString = "...@gmail.com" & @CRLF & _
"Firstname.Lastname@gmail.com" & @CRLF & _
"_._@gmail.com" & @CRLF & _
"Test_1@gmail.com" & @CRLF & _
"Test_2.Check@gmail.com" & @CRLF & _
"___@gmail.com" & @CRLF & _
"a.b.c@gmail.com" & @CRLF & _
"_@gmail.com" & @CRLF & _
"__@gmail.com" & @CRLF & _
"ab.c.@gmail.com" & @CRLF & _
"___....___@gmail.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")