import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!_+(?:[.-]?_*)*)\\w+(?:[-.]?\\w+)*@gmail\\.com$";
final String string = "...@gmail.com\n"
+ "Firstname.Lastname@gmail.com\n"
+ "_._@gmail.com\n"
+ "Test_1@gmail.com\n"
+ "Test_2.Check@gmail.com\n"
+ "___@gmail.com\n"
+ "a.b.c@gmail.com\n"
+ "_@gmail.com\n"
+ "__@gmail.com\n"
+ "ab.c.@gmail.com\n"
+ "___....___@gmail.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}