re = /^(?!_+(?:[.-]?_*)*)\w+(?:[-.]?\w+)*@gmail\.com$/m
str = '...@gmail.com
Firstname.Lastname@gmail.com
_._@gmail.com
Test_1@gmail.com
Test_2.Check@gmail.com
___@gmail.com
a.b.c@gmail.com
_@gmail.com
__@gmail.com
ab.c.@gmail.com
___....___@gmail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end