use strict;
my $str = '...@gmail.com
Firstname.Lastname@gmail.com
_._@gmail.com
Test_1@gmail.com
Test_2.Check@gmail.com
___@gmail.com
a.b.c@gmail.com
_@gmail.com
__@gmail.com
ab.c.@gmail.com
___....___@gmail.com
';
my $regex = qr/^(?!_+(?:[.-]?_*)*)\w+(?:[-.]?\w+)*@gmail\.com$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}