package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)100(\d{2})`)
var str = `10000
10001
10002
to replace 100 to 200 use
200$1 in JS
or
200\1 in Python`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}