import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "100(\\d{2})";
final String string = "10000\n"
+ "10001\n"
+ "10002\n\n"
+ "to replace 100 to 200 use\n"
+ "200$1 in JS\n"
+ "or \n"
+ "200\\1 in Python";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}