const regex = /100(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('100(\\d{2})', 'gm')
const str = `10000
10001
10002
to replace 100 to 200 use
200\$1 in JS
or
200\\1 in Python`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}