$re = '/100(\d{2})/m';
$str = '10000
10001
10002
to replace 100 to 200 use
200$1 in JS
or
200\\1 in Python';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);