#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:[^\d\s]*\d){2})[\w@#$]+$"
Local $sString = "ab3c" & @CRLF & _
"a@bc" & @CRLF & _
"a@1c" & @CRLF & _
"4" & @CRLF & _
"a2" & @CRLF & _
"" & @CRLF & _
"Test12" & @CRLF & _
"" & @CRLF & _
"12" & @CRLF & _
"1test3" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")