re = /^(?!(?:[^\d\s]*\d){2})[\w@#$]+$/m
str = 'ab3c
a@bc
a@1c
4
a2
Test12
12
1test3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end