import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:[^\\d\\s]*\\d){2})[\\w@#$]+$";
final String string = "ab3c\n"
+ "a@bc\n"
+ "a@1c\n"
+ "4\n"
+ "a2\n\n"
+ "Test12\n\n"
+ "12\n"
+ "1test3\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}