using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT aaa FROM bbb WHERE BINARY value='((?:\\.|[^'])*+)'";
string input = @"SELECT aaa FROM bbb WHERE BINARY value='cc\' \\ \\' AND value2='ddd'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}