// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)SELECT aaa FROM bbb WHERE BINARY value='((?:\\.|[^'])*+)'").unwrap();
let string = "SELECT aaa FROM bbb WHERE BINARY value='cc\\' \\\\ \\\\' AND value2='ddd'
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}