re = /SELECT aaa FROM bbb WHERE BINARY value='((?:\\.|[^'])*+)'/m
str = 'SELECT aaa FROM bbb WHERE BINARY value=\'cc\\\' \\\\ \\\\\' AND value2=\'ddd\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end