$re = '/SELECT aaa FROM bbb WHERE BINARY value=\'((?:\\\\.|[^\'])*+)\'/m';
$str = 'SELECT aaa FROM bbb WHERE BINARY value=\'cc\\\' \\\\ \\\\\' AND value2=\'ddd\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);