#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^User name:)\s*(\S.+)$"
Local $sString = "Action: NEW" & @CRLF & _
"" & @CRLF & _
"User name: Matthew Thomas" & @CRLF & _
"Job title: Dealer Account Manager" & @CRLF & _
"Direct report: Craig Carlson" & @CRLF & _
"Department: Dealer Account Management" & @CRLF & _
"Location: Milton, QLD" & @CRLF & _
"Employment type: Permanent Full Time" & @CRLF & _
"Start date: 15/07/2013" & @CRLF & _
"Finish date:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"__________________________________________" & @CRLF & _
"Decision Point 3" & @CRLF & _
"--------------" & @CRLF & _
"Read Only"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")