re = /(?<=^User name:)\s*(\S.+)$/m
str = 'Action: NEW
User name: Matthew Thomas
Job title: Dealer Account Manager
Direct report: Craig Carlson
Department: Dealer Account Management
Location: Milton, QLD
Employment type: Permanent Full Time
Start date: 15/07/2013
Finish date:
__________________________________________
Decision Point 3
--------------
Read Only'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end