import Foundation
let pattern = #"(?<=^User name:)\s*(\S.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Action: NEW
User name: Matthew Thomas
Job title: Dealer Account Manager
Direct report: Craig Carlson
Department: Dealer Account Management
Location: Milton, QLD
Employment type: Permanent Full Time
Start date: 15/07/2013
Finish date:
__________________________________________
Decision Point 3
--------------
Read Only
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)