import re
regex = re.compile(r"(?<=^User name:)\s*(\S.+)$", flags=re.MULTILINE)
test_str = ("Action: NEW\n\n"
"User name: Matthew Thomas\n"
"Job title: Dealer Account Manager\n"
"Direct report: Craig Carlson\n"
"Department: Dealer Account Management\n"
"Location: Milton, QLD\n"
"Employment type: Permanent Full Time\n"
"Start date: 15/07/2013\n"
"Finish date:\n\n\n"
"__________________________________________\n"
"Decision Point 3\n"
"--------------\n"
"Read Only")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")