using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n^\s*$";
string substitution = @"";
string input = @"var массив = [
1
1 2 3 ;
1
]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}