$re = '/\n^\s*$/m';
$str = 'var массив = [
1
1 2 3 ;
1
]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;