package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n^\s*$`)
var str = `var массив = [
1
1 2 3 ;
1
]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}