const regex = /\n^\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n^\\s*$', 'gm')
const str = `var массив = [
1
1 2 3 ;
1
]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);