const regex = new RegExp('\\s+(?=(?:(?:20)?[01]?[0-9])-(?:1[0-2]|0?[0-9])-(?:[0-2]?[0-9]|3[01]))', 'gm')
const str = `2018-03-14 06:08:18, he went on 2018-03-15 06:08:18, lets play`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);