re = /\s+(?=(?:(?:20)?[01]?[0-9])-(?:1[0-2]|0?[0-9])-(?:[0-2]?[0-9]|3[01]))/m
str = '2018-03-14 06:08:18, he went on 2018-03-15 06:08:18, lets play'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result