import re
regex = re.compile(r"\s+(?=(?:(?:20)?[01]?[0-9])-(?:1[0-2]|0?[0-9])-(?:[0-2]?[0-9]|3[01]))", flags=re.MULTILINE)
test_str = "2018-03-14 06:08:18, he went on 2018-03-15 06:08:18, lets play"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)