package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\.(\w+))|(?:\[\"([^\"]+)\"\])|(?:\[(\d+)])`)
var str = `bpy.data.test.cameras["C$amera.001"]["defocus"][1].z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}