$re = '/(?:\.(\w+))|(?:\[\"([^\"]+)\"\])|(?:\[(\d+)])/';
$str = 'bpy.data.test.cameras["C$amera.001"]["defocus"][1].z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);