re = /(?:\.(\w+))|(?:\[\"([^\"]+)\"\])|(?:\[(\d+)])/
str = 'bpy.data.test.cameras["C$amera.001"]["defocus"][1].z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end