// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\.(\w+))|(?:\[\"([^\"]+)\"\])|(?:\[(\d+)])"#).unwrap();
let string = "bpy.data.test.cameras[\"C$amera.001\"][\"defocus\"][1].z";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}