#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*([ ,'-])\1)[a-z]+(?:[ ,'-]+[a-z]+)*$"
Local $sString = "hello" & @CRLF & _
"what" & @CRLF & _
"how are you" & @CRLF & _
"the person's thing" & @CRLF & _
"how, are you" & @CRLF & _
"dash - between words" & @CRLF & _
"how-are-you" & @CRLF & _
"a-,-,-,-,b" & @CRLF & _
"" & @CRLF & _
"how are you?" & @CRLF & _
"hi5" & @CRLF & _
"8ask" & @CRLF & _
"yyyy." & @CRLF & _
"! dff" & @CRLF & _
"NoSpecialcharacters#" & @CRLF & _
"54445566" & @CRLF & _
"how are you" & @CRLF & _
"how-are------you" & @CRLF & _
"the person''s thing" & @CRLF & _
"how,, are you"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")