re = /^(?!.*([ ,'-])\1)[a-z]+(?:[ ,'-]+[a-z]+)*$/m
str = 'hello
what
how are you
the person\'s thing
how, are you
dash - between words
how-are-you
a-,-,-,-,b
how are you?
hi5
8ask
yyyy.
! dff
NoSpecialcharacters#
54445566
how are you
how-are------you
the person\'\'s thing
how,, are you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end