import re
regex = re.compile(r"^(?!.*([ ,'-])\1)[a-z]+(?:[ ,'-]+[a-z]+)*$", flags=re.MULTILINE)
test_str = ("hello\n"
"what\n"
"how are you\n"
"the person's thing\n"
"how, are you\n"
"dash - between words\n"
"how-are-you\n"
"a-,-,-,-,b\n\n"
"how are you?\n"
"hi5\n"
"8ask\n"
"yyyy.\n"
"! dff\n"
"NoSpecialcharacters#\n"
"54445566\n"
"how are you\n"
"how-are------you\n"
"the person''s thing\n"
"how,, are you")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")