using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*([ ,'-])\1)[a-z]+(?:[ ,'-]+[a-z]+)*$";
string input = @"hello
what
how are you
the person's thing
how, are you
dash - between words
how-are-you
a-,-,-,-,b
how are you?
hi5
8ask
yyyy.
! dff
NoSpecialcharacters#
54445566
how are you
how-are------you
the person''s thing
how,, are you";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}