#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[tag\]([\s\S]+)\[\/tag\]"
Local $sString = "[tag]Anything that you wishAnything that you wishAnything that you wish" & @CRLF & _
"" & @CRLF & _
"Anything that you wish" & @CRLF & _
"" & @CRLF & _
"Anything that you wish" & @CRLF & _
"" & @CRLF & _
"Anything that you wish" & @CRLF & _
"[/tag]"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)