import Foundation
let pattern = #"\[tag\]([\s\S]+)\[\/tag\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[tag]Anything that you wishAnything that you wishAnything that you wish
Anything that you wish
Anything that you wish
Anything that you wish
[/tag]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)