package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[tag\]([\s\S]+)\[\/tag\]`)
var str = `[tag]Anything that you wishAnything that you wishAnything that you wish
Anything that you wish
Anything that you wish
Anything that you wish
[/tag]`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}