$re = '/\[tag\]([\s\S]+)\[\/tag\]/m';
$str = '[tag]Anything that you wishAnything that you wishAnything that you wish
Anything that you wish
Anything that you wish
Anything that you wish
[/tag]';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;