package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+)(?:\.0+|(\.\d+?))0*\b`)
var str = `bla 500.00
bla 1.20000
bla 1.10
bla 2.34
bla 2.340003
bal 1.032`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}