const regex = /\b(\d+)(?:\.0+|(\.\d+?))0*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)(?:\\.0+|(\\.\\d+?))0*\\b', 'gm')
const str = `bla 500.00
bla 1.20000
bla 1.10
bla 2.34
bla 2.340003
bal 1.032`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);