import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+)(?:\\.0+|(\\.\\d+?))0*\\b";
final String string = "bla 500.00\n"
+ "bla 1.20000\n"
+ "bla 1.10\n"
+ "bla 2.34\n"
+ "bla 2.340003\n"
+ "bal 1.032";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}