import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^,]*,[^,0-9]*([0-9]+)";
final String string = "John, a 005, green, 01-22-18.abc\n"
+ "Sarah, 325, blue, 03-18-17.abc\n"
+ "Mike, b 56, red, 12-05-17.abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}