// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^,]*,[^,0-9]*([0-9]+)").unwrap();
let string = "John, a 005, green, 01-22-18.abc
Sarah, 325, blue, 03-18-17.abc
Mike, b 56, red, 12-05-17.abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}