re = /^[^,]*,[^,0-9]*([0-9]+)/m
str = 'John, a 005, green, 01-22-18.abc
Sarah, 325, blue, 03-18-17.abc
Mike, b 56, red, 12-05-17.abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end