const regex = /^[^,]*,[^,0-9]*([0-9]+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^,]*,[^,0-9]*([0-9]+)', 'mg')
const str = `John, a 005, green, 01-22-18.abc
Sarah, 325, blue, 03-18-17.abc
Mike, b 56, red, 12-05-17.abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}