#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^.\r\n]+\.){11}([^.\r\n]+)\.([^.\r\n]+)\.(?!ok\b|cancelled\b)([^.\r\n]+)\.(?:[^.\r\n]+)$"
Local $sString = "group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.ok.count" & @CRLF & _
"group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.cancelled.count" & @CRLF & _
"group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.error.count"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")